| SUMMARY = "Python evdev lib" |
| HOMEPAGE = "https://github.com/gvalkov/python-evdev" |
| LICENSE = "BSD-3-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2" |
| |
| SRC_URI[sha256sum] = "ecfa01b5c84f7e8c6ced3367ac95288f43cd84efbfd7dd7d0cdbfc0d18c87a6a" |
| |
| inherit pypi setuptools3 |
| |
| do_compile:prepend() { |
| rm -rf ${S}/evdev/ecodes.c |
| } |
| |
| SETUPTOOLS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h" |
| |
| RDEPENDS:${PN} += "\ |
| ${PYTHON_PN}-ctypes \ |
| ${PYTHON_PN}-fcntl \ |
| ${PYTHON_PN}-io \ |
| ${PYTHON_PN}-shell \ |
| ${PYTHON_PN}-stringold \ |
| " |