| DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema" |
| HOMEPAGE = "https://github.com/devicetree-org/dt-schema" |
| LICENSE = "BSD-2-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811" |
| |
| inherit pypi setuptools3 |
| |
| PYPI_PACKAGE = "dtschema" |
| |
| SRC_URI[sha256sum] = "f532d433a915e507d4b426b7ef57a6730d23c0938b682fb4866f9dfa80a58ec6" |
| |
| DEPENDS += "python3-setuptools-scm-native" |
| RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987" |
| |
| BBCLASSEXTEND = "native nativesdk" |