| SUMMARY = "Vulkan Header files and API registry" |
| DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \ |
| to modern GPUs with low overhead and targeting realtime graphics applications such as \ |
| games and interactive media. This package contains the development headers \ |
| for packages wanting to make use of Vulkan." |
| HOMEPAGE = "https://www.khronos.org/vulkan/" |
| BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers" |
| SECTION = "libs" |
| |
| LICENSE = "Apache-2.0 & MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1bc355d8c4196f774c8b87ed1a8dd625" |
| SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https" |
| |
| SRCREV = "7b3466a1f47a9251ac1113efbe022ff016e2f95b" |
| |
| S = "${WORKDIR}/git" |
| |
| inherit cmake |
| |
| FILES:${PN} += "${datadir}/vulkan" |
| RDEPENDS:${PN} += "python3-core" |
| |
| # These recipes need to be updated in lockstep with each other: |
| # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools, |
| # vulkan-validation-layers, vulkan-utility-libraries. |
| # The tags versions should always be sdk-x.y.z, as this is what |
| # upstream considers a release. |
| UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |