| KBRANCH ?= "v6.1/standard/base" |
| |
| require recipes-kernel/linux/linux-yocto.inc |
| |
| # CVE exclusions |
| include recipes-kernel/linux/cve-exclusion.inc |
| include recipes-kernel/linux/cve-exclusion_6.1.inc |
| |
| SRCREV_machine ?= "6c78fd37122b29c40bd8bb6f43aaa1ba7d6fb53a" |
| SRCREV_meta ?= "40dede8a165ea5894f172fede6baa0dd94d23fec" |
| |
| # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll |
| # get the <version>/base branch, which is pure upstream -stable, and the same |
| # meta SRCREV as the linux-yocto-standard builds. Select your version using the |
| # normal PREFERRED_VERSION settings. |
| BBCLASSEXTEND = "devupstream:target" |
| SRCREV_machine:class-devupstream ?= "fec3b1451d5febbc9e04250f879c10f8952e6bed" |
| PN:class-devupstream = "linux-yocto-upstream" |
| KBRANCH:class-devupstream = "v6.1/base" |
| |
| SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH};protocol=https \ |
| git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https" |
| SRC_URI += "file://0001-perf-cpumap-Make-counter-as-unsigned-ints.patch" |
| |
| LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" |
| LINUX_VERSION ?= "6.1.73" |
| |
| PV = "${LINUX_VERSION}+git" |
| |
| KMETA = "kernel-meta" |
| KCONF_BSP_AUDIT_LEVEL = "1" |
| |
| # Functionality flags |
| KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc" |
| KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}" |
| KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}" |
| KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}" |
| KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}" |