| DESCRIPTION = "Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms." |
| AUTHOR = "Benoît Jacob and Gaël Guennebaud and others" |
| HOMEPAGE = "http://eigen.tuxfamily.org/" |
| LICENSE = "MPL-2.0" |
| LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad" |
| |
| SRC_URI = "git://gitlab.com/libeigen/eigen.git;protocol=http;nobranch=1" |
| |
| SRCREV = "21ae2afd4edaa1b69782c67a54182d34efe43f9c" |
| |
| S = "${WORKDIR}/git" |
| |
| inherit cmake |
| |
| FILES_${PN} = "${libdir}" |
| FILES_${PN}-dev = "${includedir} ${datadir}/eigen3/cmake ${datadir}/cmake/Modules ${datadir}/pkgconfig" |
| |
| # ${PN} is empty so we need to tweak -dev and -dbg package dependencies |
| RDEPENDS_${PN}-dev = "" |
| RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |
| |
| BBCLASSEXTEND = "native nativesdk" |