| SUMMARY = "Window navigation construction toolkit" |
| LICENSE = "LGPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| |
| GNOMEBASEBUILDCLASS = "meson" |
| |
| inherit gnomebase gsettings gobject-introspection gettext features_check upstream-version-is-even |
| |
| DEPENDS = " \ |
| colord \ |
| geocode-glib \ |
| gcr \ |
| gnome-desktop \ |
| libgweather \ |
| lcms \ |
| libcanberra \ |
| geoclue \ |
| libnotify \ |
| upower \ |
| libwacom \ |
| virtual/libx11 \ |
| " |
| |
| # all these are mandatory |
| REQUIRED_DISTRO_FEATURES = "x11 polkit pulseaudio systemd gobject-introspection-data" |
| GIR_MESON_OPTION = "" |
| |
| SRC_URI += " file://0001-build-remove-positional-i18n.merge_file-arguments.patch" |
| SRC_URI[archive.sha256sum] = "e6ca6361fbd1deab2de1a1e390d4f14167cf47b1c547dbb8b65a5d89e9663884" |
| |
| PACKAGECONFIG ??= " \ |
| cups nm \ |
| alsa gudev \ |
| smartcard \ |
| ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \ |
| " |
| PACKAGECONFIG[alsa] = "-Dalsa=true,-Dalsa=false,alsa-lib" |
| PACKAGECONFIG[cups] = "-Dcups=true,-Dcups=false,cups" |
| PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev" |
| PACKAGECONFIG[nm] = "-Dnetwork_manager=true,-Dnetwork_manager=false,networkmanager" |
| PACKAGECONFIG[smartcard] = "-Dsmartcard=true,-Dsmartcard=false,nss" |
| PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland" |
| |
| FILES:${PN} += " \ |
| ${systemd_user_unitdir} \ |
| ${libdir}/gnome-settings-daemon-41/libgsd.so \ |
| " |