| EXTRA_OEMAKE_append_libc-musl = "\ |
| gt_cv_func_gnugettext1_libc=yes \ |
| gt_cv_func_gnugettext2_libc=yes \ |
| gl_cv_func_gettimeofday_clobber=no \ |
| if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then |
| cat > ${WORKDIR}/python << EOF |
| --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;; |
| --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;; |
| --exec-prefix) echo "${exec_prefix}" ;; |
| chmod +x ${WORKDIR}/python |
| CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday" |