| SUMMARY = "Implements a XML/HTML/XHTML Markup safe string for Python" |
| HOMEPAGE = "http://github.com/mitsuhiko/markupsafe" |
| LICENSE = "BSD-3-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| |
| SRC_URI[sha256sum] = "abcabc8c2b26036d62d4c746381a6f7cf60aafcc653198ad678306986b09450d" |
| |
| PYPI_PACKAGE = "MarkupSafe" |
| inherit pypi setuptools3 ptest |
| |
| RDEPENDS:${PN} += "${PYTHON_PN}-stringold" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| ${PYTHON_PN}-unittest-automake-output \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |