| SUMMARY = "Destined to fail" |
| INHIBIT_DEFAULT_DEPS = "1" |
| echo "This is shell stdout" |
| echo "This is shell stderr" >&2 |
| python do_pythontest_exec_func_shell() { |
| bb.build.exec_func('do_shelltest', d) |
| addtask do_pythontest_exec_func_shell |
| python do_pythontest_exit () { |
| print("This is python stdout") |
| addtask do_pythontest_exit |
| python do_pythontest_exec_func_python() { |
| bb.build.exec_func('do_pythontest_exit', d) |
| addtask do_pythontest_exec_func_python |
| python do_pythontest_fatal () { |
| print("This is python fatal test stdout") |
| bb.fatal("This is a fatal error") |
| addtask do_pythontest_fatal |