| DESCRIPTION = "Implementation of the PLDM specifications" |
| DEPENDS += "phosphor-dbus-interfaces" |
| DEPENDS += "nlohmann-json" |
| DEPENDS += "phosphor-logging" |
| SYSTEMD_SERVICE:${PN} += "pldmd.service" |
| SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service" |
| LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service" |
| LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service" |
| # Install pldmSoftPowerOff.service in correct targets |
| mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants |
| LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service" |
| TARGET="../pldmSoftPowerOff.service" |
| mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants |
| LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service" |
| TARGET="../pldmSoftPowerOff.service" |