| SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" |
| HOMEPAGE = "https://pypi.org/project/setuptools" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=141643e11c48898150daa83802dbc65f" |
| inherit pypi python_setuptools_build_meta |
| SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch" |
| file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch" |
| SRC_URI[sha256sum] = "0ff4183f8f42cd8fa3acea16c45205521a4ef28f73c6391d8a25e92893134f2e" |
| BBCLASSEXTEND = "native nativesdk" |
| # The pkg-resources module can be used by itself, without the package downloader |
| # and easy_install. Ship it in a separate package so that it can be used by |
| PACKAGES =+ "python3-pkg-resources " |
| FILES:python3-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*" |
| RDEPENDS:python3-pkg-resources = "\ |
| # This used to use the bootstrap install which didn't compile. Until we bump the |
| # tmpdir version we can't compile the native otherwise the sysroot unpack fails |
| INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |