| require ruby.inc |
| |
| SRC_URI += " \ |
| file://ruby-CVE-2017-9226.patch \ |
| file://ruby-CVE-2017-9228.patch \ |
| " |
| |
| SRC_URI[md5sum] = "f4711f856fe14de222b9da3d3b8efa89" |
| SRC_URI[sha256sum] = "46e6f3630f1888eb653b15fa811d77b5b1df6fd7a3af436b343cfe4f4503f2ab" |
| |
| # it's unknown to configure script, but then passed to extconf.rb |
| # maybe it's not really needed as we're hardcoding the result with |
| # 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch |
| UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo" |
| |
| PACKAGECONFIG ??= "" |
| PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| |
| PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind" |
| PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp" |
| PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo," |
| |
| EXTRA_AUTORECONF += "--exclude=aclocal" |
| |
| EXTRA_OECONF = "\ |
| --disable-versioned-paths \ |
| --disable-rpath \ |
| --disable-dtrace \ |
| --enable-shared \ |
| --enable-load-relative \ |
| " |
| |
| do_install() { |
| oe_runmake 'DESTDIR=${D}' install |
| } |
| |
| PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc" |
| |
| SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library" |
| RDEPENDS_${PN}-ri-docs = "${PN}" |
| FILES_${PN}-ri-docs += "${datadir}/ri" |
| |
| SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source" |
| RDEPENDS_${PN}-rdoc = "${PN}" |
| FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc" |
| |
| FILES_${PN} += "${datadir}/rubygems" |
| |
| BBCLASSEXTEND = "native" |