| require gstreamer1.0-plugins-common.inc |
| |
| SUMMARY = "'Base' GStreamer plugins and helper libraries" |
| HOMEPAGE = "https://gstreamer.freedesktop.org/" |
| BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues" |
| LICENSE = "LGPL-2.1-or-later" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770" |
| |
| SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \ |
| file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ |
| file://0003-viv-fb-Make-sure-config.h-is-included.patch \ |
| file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ |
| " |
| SRC_URI[sha256sum] = "292424e82dea170528c42b456f62a89532bcabc0508f192e34672fb86f68e5b8" |
| |
| S = "${WORKDIR}/gst-plugins-base-${PV}" |
| |
| DEPENDS += "iso-codes util-linux zlib" |
| |
| inherit gobject-introspection |
| |
| # opengl packageconfig factored out to make it easy for distros |
| # and BSP layers to choose OpenGL APIs/platforms/window systems |
| PACKAGECONFIG_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'opengl glx', '', d)}" |
| PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl ${PACKAGECONFIG_X11}', '', d)}" |
| |
| PACKAGECONFIG ??= " \ |
| ${GSTREAMER_ORC} \ |
| ${PACKAGECONFIG_GL} \ |
| ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \ |
| jpeg ogg pango png theora vorbis \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ |
| " |
| |
| OPENGL_APIS = 'opengl gles2' |
| OPENGL_PLATFORMS = 'egl glx' |
| |
| X11DEPENDS = "virtual/libx11 libsm libxrender libxv" |
| X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled" |
| X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled" |
| |
| PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib" |
| PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia" |
| PACKAGECONFIG[graphene] = "-Dgl-graphene=enabled,-Dgl-graphene=disabled,graphene" |
| PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg" |
| PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg" |
| PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus" |
| PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango" |
| PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng" |
| # This enables Qt5 QML examples in -base. The Qt5 GStreamer |
| # qmlglsink and qmlglsrc plugins still exist in -good. |
| PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native" |
| PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora" |
| PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor" |
| PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual" |
| PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis" |
| PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" |
| |
| # OpenGL API packageconfigs |
| PACKAGECONFIG[opengl] = ",,virtual/libgl libglu" |
| PACKAGECONFIG[gles2] = ",,virtual/libgles2" |
| |
| # OpenGL platform packageconfigs |
| PACKAGECONFIG[egl] = ",,virtual/egl" |
| PACKAGECONFIG[glx] = ",,virtual/libgl" |
| |
| # OpenGL window systems (except for X11) |
| PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm" |
| PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm" |
| PACKAGECONFIG[dispmanx] = ",,virtual/libomxil" |
| PACKAGECONFIG[viv-fb] = ",,virtual/libgles2 virtual/libg2d" |
| |
| OPENGL_WINSYS = "${@bb.utils.filter('PACKAGECONFIG', 'x11 gbm wayland dispmanx egl viv-fb', d)}" |
| |
| EXTRA_OEMESON += " \ |
| -Ddoc=disabled \ |
| ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \ |
| ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \ |
| ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \ |
| " |
| |
| FILES:${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h" |
| FILES:${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict" |
| |
| def get_opengl_cmdline_list(switch_name, options, d): |
| selected_options = [] |
| if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d): |
| for option in options.split(): |
| if bb.utils.contains('PACKAGECONFIG', option, True, False, d): |
| selected_options += [option] |
| if selected_options: |
| return '-D' + switch_name + '=' + ','.join(selected_options) |
| else: |
| return '' |
| |
| CVE_PRODUCT += "gst-plugins-base" |