| SUMMARY = "foxconn OEM IPMI commands" |
| DESCRIPTION = "foxconn OEM IPMI commands" |
| |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| |
| S = "${WORKDIR}/git" |
| |
| DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod" |
| |
| inherit cmake obmc-phosphor-ipmiprovider-symlink |
| |
| EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1" |
| |
| LIBRARY_NAMES = "libfiioemcmds.so" |
| |
| SRC_URI = "git://github.com/openbmc/foxconn-ipmi-oem.git" |
| SRCREV = "163226efd02b91994aaa474005979560965ac3d6" |
| |
| HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| |
| FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}" |