| SUMMARY = "Plugin and hook calling mechanisms for python" |
| HOMEPAGE = "https://github.com/pytest-dev/pluggy" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2" |
| |
| SRC_URI[md5sum] = "7f610e28b8b34487336b585a3dfb803d" |
| SRC_URI[sha256sum] = "15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0" |
| |
| DEPENDS += "${PYTHON_PN}-setuptools-scm-native" |
| RDEPENDS_${PN} += "${PYTHON_PN}-importlib-metadata \ |
| ${PYTHON_PN}-more-itertools \ |
| " |
| |
| inherit pypi ptest setuptools3 |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS_${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/testing |
| cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/ |
| } |