| python __anonymous() { |
| if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"): |
| msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \ |
| "provider of virtual/kernel." |
| raise bb.parse.SkipRecipe(msg) |
| } |
| |
| LINUX_VERSION ?= "5.10.y" |
| LINUX_RPI_BRANCH ?= "rpi-5.10.y" |
| LINUX_RPI_KMETA_BRANCH ?= "yocto-5.10" |
| |
| # Set default SRCREVs. Both the machine and meta SRCREVs are statically set |
| # to the as in 5.10 recipe, and hence prevent network access during parsing. If |
| # linux-yocto-dev is the preferred provider, they will be overridden to |
| # AUTOREV in following anonymous python routine and resolved when the |
| # variables are finalized. |
| SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-raspberrypi-dev", "${AUTOREV}", "89399e6e7e33d6260a954603ca03857df594ffd3", d)}' |
| SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-raspberrypi-dev", "${AUTOREV}", "a19886b00ea7d874fdd60d8e3435894bb16e6434", d)}' |
| |
| KMETA = "kernel-meta" |
| |
| SRC_URI = " \ |
| git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH};protocol=https \ |
| git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${LINUX_RPI_KMETA_BRANCH};destsuffix=${KMETA} \ |
| file://powersave.cfg \ |
| file://android-drivers.cfg \ |
| " |
| |
| require linux-raspberrypi.inc |
| |
| KERNEL_DTC_FLAGS += "-@ -H epapr" |
| |
| # Disable version check so that we don't have to edit this recipe every time |
| # upstream bumps the version |
| KERNEL_VERSION_SANITY_SKIP = "1" |