| SUMMARY = "XWayland is an X Server that runs under Wayland." |
| DESCRIPTION = "XWayland is an X Server running as a Wayland client, \ |
| and thus is capable of displaying native X11 client applications in a \ |
| Wayland compositor environment. The goal of XWayland is to facilitate \ |
| the transition from X Window System to Wayland environments, providing \ |
| a way to run unported applications in the meantime." |
| HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone" |
| |
| LICENSE = "MIT-X" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880" |
| |
| SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz" |
| SRC_URI[sha256sum] = "31f261ce51bbee76a6ca3ec02aa367ffa2b5efa2b98412df57ccefd7a19003ce" |
| |
| inherit meson features_check |
| REQUIRED_DISTRO_FEATURES = "x11 opengl" |
| |
| DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy" |
| |
| do_install_append() { |
| # remove files not needed and clashing with xserver-xorg |
| rm -rf ${D}/${libdir}/xorg/ |
| } |
| |
| FILES_${PN} += "${libdir}/xorg/protocol.txt" |
| |