| SUMMARY = "Open POWER DBus Interfaces" |
| DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML" |
| PR = "r1" |
| PV = "1.0+git${SRCPV}" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| |
| S = "${WORKDIR}/git" |
| |
| inherit autotools pkgconfig |
| inherit pythonnative |
| inherit phosphor-dbus-yaml |
| |
| DEPENDS += "autoconf-archive-native" |
| DEPENDS += "sdbus++-native" |
| DEPENDS += "phosphor-dbus-interfaces" |
| |
| SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces" |
| SRCREV = "109ded04f3fec7bbbd93f9c9956a355f4894a51f" |
| |
| DEPENDS_remove_class-native = "sdbus++-native" |
| DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| |
| PACKAGECONFIG ??= "libopenpower_dbus" |
| PACKAGECONFIG[libopenpower_dbus] = " \ |
| --enable-libopenpower_dbus, \ |
| --disable-libopenpower_dbus, \ |
| systemd sdbusplus, \ |
| libsystemd sdbusplus \ |
| " |
| |
| PACKAGECONFIG_remove_class-native = "libopenpower_dbus" |
| PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus" |
| |
| BBCLASSEXTEND += "native nativesdk" |