| SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| Contributors." |
| HOMEPAGE = "https://pillow.readthedocs.io" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=ea2dc3f5611e69058503d4b940049d03" |
| |
| SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=7.2.x \ |
| file://0001-support-cross-compiling.patch \ |
| file://0001-explicitly-set-compile-options.patch \ |
| " |
| SRCREV ?= "2bd74943fb9f320def6c066e732b701d1c15f677" |
| |
| |
| inherit setuptools3 |
| |
| DEPENDS += " \ |
| zlib \ |
| jpeg \ |
| tiff \ |
| freetype \ |
| lcms \ |
| openjpeg \ |
| " |
| |
| RDEPENDS_${PN} += " \ |
| ${PYTHON_PN}-misc \ |
| ${PYTHON_PN}-logging \ |
| ${PYTHON_PN}-numbers \ |
| " |
| |
| CVE_PRODUCT = "pillow" |
| |
| S = "${WORKDIR}/git" |
| |
| RPROVIDES_${PN} += "python3-imaging" |
| |
| BBCLASSEXTEND = "native" |