| SUMMARY = "OpenPOWER Debug Collector" |
| DESCRIPTION = "Application to log error during host checkstop and watchdog timeout" |
| |
| PR = "r1" |
| PV = "1.0+git${SRCPV}" |
| |
| inherit autotools \ |
| pkgconfig \ |
| obmc-phosphor-systemd \ |
| python3native \ |
| phosphor-dbus-yaml |
| |
| require ${BPN}.inc |
| require ${BPN}-systemd-links.inc |
| |
| DEPENDS += " \ |
| phosphor-logging \ |
| autoconf-archive-native \ |
| ${PYTHON_PN}-sdbus++-native \ |
| " |
| S = "${WORKDIR}/git" |
| |
| # This provides below 2 applications that are called into in case |
| # of host checkstop and host watchdog timeout respectively. |
| APPS = "checkstop watchdog" |
| |
| DEBUG_TMPL = "openpower-debug-collector-{0}@.service" |
| SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}" |
| |
| |
| # Do not depend on phosphor-logging for native build |
| DEPENDS_remove_class-native = "phosphor-logging" |
| |
| # Do not depend on phosphor-logging for native SDK build |
| DEPENDS_remove_class-nativesdk = "phosphor-logging" |
| |
| # Provide a means to enable/disable install_error_yaml feature |
| PACKAGECONFIG ??= "install_error_yaml" |
| PACKAGECONFIG[install_error_yaml] = " \ |
| --enable-install_error_yaml, \ |
| --disable-install_error_yaml, ,\ |
| " |
| |
| # Enable install_error_yaml during native and native SDK build |
| PACKAGECONFIG_add_class-native = "install_error_yaml" |
| PACKAGECONFIG_add_class-nativesdk = "install_error_yaml" |
| |
| # Disable install_error_yaml during target build |
| PACKAGECONFIG_remove_class-target = "install_error_yaml" |
| |
| # Disable generating elog error header file during bitbake. Applications |
| # should be using the elog header generated by phosphor-logging recipe |
| EXTRA_OECONF += "--disable-gen_errors" |
| |
| BBCLASSEXTEND += "native nativesdk" |