| SUMMARY = "General-purpose library specifically developed for the WPE-flavored port of WebKit." |
| HOMEPAGE = "https://github.com/WebPlatformForEmbedded/libwpe" |
| BUGTRACKER = "https://github.com/WebPlatformForEmbedded/libwpe/issues" |
| |
| LICENSE = "BSD" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc" |
| DEPENDS = "virtual/egl libxkbcommon" |
| |
| # Workaround build issue with RPi userland EGL libraries. |
| CFLAGS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}" |
| |
| inherit cmake features_check |
| |
| REQUIRED_DISTRO_FEATURES = "opengl" |
| |
| SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz" |
| SRC_URI[sha256sum] = "a6f00a7d091cbd4db57fe7ee3b4c12c6350921d654ed79812800a26c888481d2" |
| |
| # This is a tweak of upstream-version-is-even needed because |
| # ipstream directory contains tarballs for other components as well. |
| UPSTREAM_CHECK_REGEX = "libwpe-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar" |