| SUMMARY = "Vulkan Header files and API registry" |
| DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \ |
| to modern GPUs with low overhead and targeting realtime graphics applications such as \ |
| games and interactive media. This package contains the development headers \ |
| for packages wanting to make use of Vulkan." |
| HOMEPAGE = "https://www.khronos.org/vulkan/" |
| BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers" |
| SECTION = "libs" |
| |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https" |
| |
| SRCREV = "65ad768d8603671fc1085fe115019e72a595ced8" |
| |
| S = "${WORKDIR}/git" |
| |
| inherit cmake |
| |
| FILES:${PN} += "${datadir}/vulkan" |
| RDEPENDS:${PN} += "python3-core" |
| |
| # These recipes need to be updated in lockstep with each other: |
| # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools |
| # The tags versions should always be sdk-x.y.z, as this is what |
| # upstream considers a release. |
| UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |