| SUMMARY = "msmtp is an SMTP client" |
| DESCRIPTION = "A sendmail replacement for use in MTAs like mutt" |
| HOMEPAGE = "https://marlam.de/msmtp/" |
| SECTION = "console/network" |
| |
| LICENSE = "GPLv3" |
| DEPENDS = "zlib gnutls" |
| |
| LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| |
| UPSTREAM_CHECK_URI = "https://marlam.de/msmtp/download/" |
| |
| SRC_URI = "https://marlam.de/${BPN}/releases/${BP}.tar.xz" |
| SRC_URI[md5sum] = "abfabb92f0461137f3c09cd16d98fc9b" |
| SRC_URI[sha256sum] = "e5dd7fe95bc8e2f5eea3e4894ec9628252f30bd700a7fd1a568b10efa91129f7" |
| |
| inherit gettext autotools update-alternatives pkgconfig |
| |
| EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn" |
| |
| ALTERNATIVE_${PN} = "sendmail" |
| ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp" |
| ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail" |
| ALTERNATIVE_PRIORITY = "100" |
| |
| pkg_postinst_${PN}_linuxstdbase () { |
| # /usr/lib/sendmial is required by LSB core test |
| [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/ |
| } |