SUMMARY = "The module provides handy URL class for url parsing and changing" | |
HOMEPAGE = "https://github.com/aio-libs/yarl/" | |
LICENSE = "Apache-2.0" | |
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | |
SRC_URI[sha256sum] = "04ab9d4b9f587c06d801c2abfe9317b77cdf996c65a90d5e84ecc45010823571" | |
SRC_URI += "file://run-ptest" | |
PYPI_PACKAGE = "yarl" | |
inherit pypi ptest setuptools3 | |
RDEPENDS:${PN} = "\ | |
${PYTHON_PN}-multidict \ | |
${PYTHON_PN}-idna \ | |
${PYTHON_PN}-io \ | |
" | |
RDEPENDS:${PN}-ptest += " \ | |
${PYTHON_PN}-pytest \ | |
" | |
do_install_ptest() { | |
install -d ${D}${PTEST_PATH}/tests | |
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | |
} |