| SUMMARY = "PNG image format decoding library" |
| DESCRIPTION = "An open source project to develop and maintain the reference \ |
| library for use in applications that read, create, and manipulate PNG \ |
| (Portable Network Graphics) raster image files. " |
| HOMEPAGE = "http://www.libpng.org/" |
| SECTION = "libs" |
| LICENSE = "Libpng" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=0fdbfbe10fc294a6fca24dc76134222a" |
| DEPENDS = "zlib" |
| |
| LIBV = "16" |
| |
| SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/${BP}.tar.xz" |
| SRC_URI[sha256sum] = "c919dbc11f4c03b05aba3f8884d8eb7adfe3572ad228af972bb60057bdb48450" |
| |
| MIRRORS += "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/older-releases/" |
| |
| UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html" |
| |
| BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config" |
| |
| inherit autotools binconfig-disabled pkgconfig |
| |
| # Work around missing symbols |
| ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}" |
| ARMNEON:aarch64 = "--enable-hardware-optimizations=on" |
| EXTRA_OECONF += "${ARMNEON}" |
| |
| PACKAGES =+ "${PN}-tools" |
| |
| FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp" |
| |
| BBCLASSEXTEND = "native nativesdk" |