| SUMMARY = "A fully featured modbus protocol stack in python" |
| HOMEPAGE = "https://github.com/riptideio/pymodbus/" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=430604f78bee72425da231d42eac9cee" |
| DEPENDS += "python3-six-native" |
| SRC_URI[sha256sum] = "82787121e293f31095c0e9721b3e561a01807a6ac20abcbfb187ce70d24fb40c" |
| S = "${WORKDIR}/pymodbus-${PV}" |
| PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio" |
| PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio" |
| PACKAGECONFIG[tornado] = ",,,python3-tornado" |
| PACKAGECONFIG[twisted] = ",,,python3-twisted-conch" |
| PACKAGECONFIG[redis] = ",,,python3-redis" |
| PACKAGECONFIG[sql] = ",,,python3-sqlalchemy" |