| SUMMARY="Pylint is a Python source code analyzer" |
| HOMEPAGE= "http://www.pylint.org/" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9" |
| git://github.com/pylint-dev/pylint;branch=main;protocol=https \ |
| file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \ |
| file://0001-pylint-remove-plugin-pickle-test.patch \ |
| SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85" |
| inherit python_setuptools_build_meta ptest |
| RDEPENDS:${PN} += "${PYTHON_PN}-astroid \ |
| ${PYTHON_PN}-platformdirs \ |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest-benchmark \ |
| ${PYTHON_PN}-pytest-runner \ |
| ${PYTHON_PN}-pytest-timeout \ |
| ${PYTHON_PN}-pytest-xdist \ |
| ${PYTHON_PN}-statistics \ |
| ${PYTHON_PN}-typing-extensions \ |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript |