| SUMMARY = "Implements a XML/HTML/XHTML Markup safe string for Python" |
| HOMEPAGE = "http://github.com/mitsuhiko/markupsafe" |
| LICENSE = "BSD-3-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| |
| SRC_URI[sha256sum] = "d283d37a890ba4c1ae73ffadf8046435c76e7bc2247bbb63c00bd1a709c6544b" |
| |
| PYPI_PACKAGE = "MarkupSafe" |
| inherit pypi python_setuptools_build_meta ptest |
| |
| RDEPENDS:${PN} += "python3-stringold" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| python3-pytest \ |
| python3-unittest-automake-output \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |