| SUMMARY = "Core utilities for Python packages" |
| HOMEPAGE = "https://github.com/pypa/packaging" |
| LICENSE = "Apache-2.0 | BSD-2-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91" |
| |
| SRC_URI[sha256sum] = "048fb0e9405036518eaaf48a55953c750c11e1a1b68e0dd1a9d62ed0c092cfc5" |
| |
| inherit pypi python_flit_core |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| # Bootstrap the native build |
| DEPENDS:remove:class-native = "python3-build-native" |
| RDEPENDS:${PN} += "python3-profile" |
| |
| do_compile:class-native () { |
| python_flit_core_do_manual_build |
| } |