| SUMMARY = "Plugin and hook calling mechanisms for python" |
| HOMEPAGE = "https://github.com/pytest-dev/pluggy" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2" |
| |
| SRC_URI[sha256sum] = "8c85c2876142a764e5b7548e7d9a0e0ddb46f5185161049a79b7e974454223be" |
| |
| DEPENDS += "python3-setuptools-scm-native" |
| RDEPENDS:${PN} += "python3-importlib-metadata \ |
| python3-more-itertools \ |
| " |
| |
| inherit pypi ptest python_setuptools_build_meta |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| python3-pytest \ |
| python3-unittest-automake-output \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/testing |
| cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/ |
| } |
| |
| BBCLASSEXTEND = "native nativesdk" |