| DESCRIPTION = "Modern password hashing for your software and your servers." |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c" |
| HOMEPAGE = "https://pypi.org/project/bcrypt/" |
| |
| DEPENDS += "${PYTHON_PN}-cffi-native" |
| |
| SRC_URI[sha256sum] = "433c410c2177057705da2a9f2cd01dd157493b2a7ac14c8593a16b3dab6b6bfb" |
| |
| inherit pypi python_setuptools_build_meta ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |
| |
| RDEPENDS:${PN}:class-target += "\ |
| ${PYTHON_PN}-cffi \ |
| ${PYTHON_PN}-ctypes \ |
| ${PYTHON_PN}-shell \ |
| ${PYTHON_PN}-six \ |
| " |