| # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. |
| SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" |
| HOMEPAGE = " http://golang.org/" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" |
| SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" |
| SRC_URI[go_linux_amd64.sha256sum] = "4a7fa60f323ee1416a4b1425aefc37ea359e9d64df19c326a58953a97ad41ea5" |
| SRC_URI[go_linux_arm64.sha256sum] = "fe5b6f6e441f3cb7b53ebf1a010bbebcb720ac98124984cfe2e51d72b8a58c71" |
| UPSTREAM_CHECK_URI = "https://golang.org/dl/" |
| UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" |
| cat <<END >${D}${bindir}/$1 |
| export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" |
| \$here/../lib/go/bin/$1 "\$@" |
| chmod +x ${D}${bindir}/$1 |
| find ${S} -depth -type d -name testdata -exec rm -rf {} + |
| install -d ${D}${bindir} ${D}${libdir}/go |
| cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ |
| make_wrapper `basename $f` |