| SUMMARY = "Enable Linux trace events" |
| DESCRIPTION = "Enable Linux trace events based on a configuration file" |
| LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| SRC_URI += " file://trace-enable" |
| SYSTEMD_SERVICE:${PN} = "trace-enable.service" |
| inherit obmc-phosphor-systemd |
| install -d ${D}${sysconfdir} |
| for event in ${TRACE_EVENTS} |
| echo ${event} >> ${D}${sysconfdir}/trace-events.conf |
| echo >> ${D}${sysconfdir}/trace-events.conf |
| chmod 0644 ${D}${sysconfdir}/trace-events.conf |
| install -d ${D}${libexecdir} |
| install -m 0755 ${WORKDIR}/trace-enable ${D}${libexecdir} |
| ${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'} \ |
| FILES:${PN} += "${sysconfdir}/trace-events.conf" |
| FILES:${PN} += "${libexecdir}/trace-enable" |