| SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed." |
| DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \ |
| By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \ |
| polling, WebSockets, and other applications that require a long-lived connection to each user." |
| HOMEPAGE = "http://www.tornadoweb.org/en/stable/" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| |
| SRC_URI[md5sum] = "f324f5e7607798552359d6ab054c4321" |
| SRC_URI[sha256sum] = "33c6e81d7bd55b468d2e793517c909b139960b6c790a60b7991b9b6b76fb9791" |
| |
| inherit pypi setuptools3 |
| |
| # Requires _compression which is currently located in misc |
| RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \ |
| ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \ |
| ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc" |
| |
| RDEPENDS:${PN}-test += "${PN} ${PYTHON_PN}-unittest" |
| |
| PACKAGES =+ "\ |
| ${PN}-test \ |
| " |
| |
| FILES:${PN}-test = " \ |
| ${libdir}/${PYTHON_DIR}/site-packages/*/test \ |
| ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \ |
| " |