| DESCRIPTION = "Google gRPC" |
| HOMEPAGE = "http://www.grpc.io/" |
| SECTION = "devel/python" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| |
| DEPENDS += "${PYTHON_PN}-protobuf" |
| |
| SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
| SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \ |
| file://boring_ssl.patch \ |
| file://mips_bigendian.patch \ |
| file://0001-absl-always-use-asm-sgidefs.h.patch \ |
| " |
| SRC_URI[sha256sum] = "57974361a459d6fe04c9ae0af1845974606612249f467bbd2062d963cb90f407" |
| |
| RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \ |
| ${PYTHON_PN}-setuptools \ |
| ${PYTHON_PN}-six \ |
| " |
| |
| inherit setuptools3 |
| inherit pypi |
| |
| export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" |
| |
| BORING_SSL_PLATFORM:arm = "linux-arm" |
| BORING_SSL_PLATFORM:x86-64 = "linux-x86_64" |
| BORING_SSL_PLATFORM ?= "unsupported" |
| export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}" |
| |
| BORING_SSL:x86-64 = "1" |
| BORING_SSL:arm = "1" |
| BORING_SSL ?= "0" |
| export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}" |
| |
| GRPC_CFLAGS ?= "" |
| GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" |
| export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}" |
| |
| CLEANBROKEN = "1" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| CCACHE_DISABLE = "1" |
| |
| # needs vdso support |
| COMPATIBLE_HOST:libc-musl:powerpc64le = "null" |