| SUMMARY = "Simple powerful testing with python" |
| HOMEPAGE = "https://pypi.org/project/pytest/" |
| DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries." |
| |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b" |
| |
| SRC_URI += "file://0001-Allow-pluggy-1.0.patch" |
| SRC_URI[sha256sum] = "50bcad0a0b9c5a72c8e4e7c9855a3ad496ca6a881a3641b4260605450772c54b" |
| |
| DEPENDS = "python3-setuptools-scm-native" |
| |
| inherit update-alternatives pypi setuptools3 |
| |
| RDEPENDS:${PN}:class-target += " \ |
| ${PYTHON_PN}-atomicwrites \ |
| ${PYTHON_PN}-attrs \ |
| ${PYTHON_PN}-debugger \ |
| ${PYTHON_PN}-doctest \ |
| ${PYTHON_PN}-importlib-metadata \ |
| ${PYTHON_PN}-iniconfig \ |
| ${PYTHON_PN}-json \ |
| ${PYTHON_PN}-more-itertools \ |
| ${PYTHON_PN}-packaging \ |
| ${PYTHON_PN}-pathlib2 \ |
| ${PYTHON_PN}-pluggy \ |
| ${PYTHON_PN}-py \ |
| ${PYTHON_PN}-setuptools \ |
| ${PYTHON_PN}-six \ |
| ${PYTHON_PN}-toml \ |
| ${PYTHON_PN}-wcwidth \ |
| " |
| |
| ALTERNATIVE:${PN} += "py.test pytest" |
| |
| NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" |
| ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" |
| |
| ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" |
| ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" |
| |
| BBCLASSEXTEND = "native nativesdk" |