| SUMMARY = "Multiplexing terminal manager" |
| DESCRIPTION = "Screen is a full-screen window manager \ |
| that multiplexes a physical terminal between several \ |
| processes, typically interactive shells." |
| HOMEPAGE = "http://www.gnu.org/software/screen/" |
| BUGTRACKER = "https://savannah.gnu.org/bugs/?func=additem&group=screen" |
| |
| SECTION = "console/utils" |
| |
| LICENSE = "GPLv3+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| file://screen.h;endline=26;md5=b8dc717c9a3dba842ae6c44ca0f73f52 \ |
| " |
| |
| DEPENDS = "ncurses virtual/crypt \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| RDEPENDS_${PN} = "base-files" |
| |
| SRC_URI = "${GNU_MIRROR}/screen/screen-${PV}.tar.gz \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://screen.pam', '', d)} \ |
| file://0002-comm.h-now-depends-on-term.h.patch \ |
| file://0001-fix-for-multijob-build.patch \ |
| file://0001-Remove-more-compatibility-stuff.patch \ |
| file://CVE-2021-26937.patch \ |
| " |
| |
| SRC_URI[md5sum] = "d276213d3acd10339cd37848b8c4ab1e" |
| SRC_URI[sha256sum] = "6e11b13d8489925fde25dfb0935bf6ed71f9eb47eff233a181e078fde5655aa1" |
| |
| inherit autotools texinfo |
| |
| PACKAGECONFIG ??= "" |
| PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter," |
| |
| EXTRA_OECONF = "--with-pty-mode=0620 --with-pty-group=5 --with-sys-screenrc=${sysconfdir}/screenrc \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)}" |
| |
| do_install_append () { |
| install -D -m 644 ${S}/etc/etcscreenrc ${D}/${sysconfdir}/screenrc |
| if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then |
| install -D -m 644 ${WORKDIR}/screen.pam ${D}/${sysconfdir}/pam.d/screen |
| fi |
| } |
| |
| pkg_postinst_${PN} () { |
| grep -q "^${bindir}/screen$" $D${sysconfdir}/shells || echo ${bindir}/screen >> $D${sysconfdir}/shells |
| } |
| |
| pkg_postrm_${PN} () { |
| printf "$(grep -v "^${bindir}/screen$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells |
| } |