| SUMMARY = "Weston, a Wayland compositor" |
| DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" |
| HOMEPAGE = "http://wayland.freedesktop.org" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \ |
| file://libweston/compositor.c;endline=27;md5=6c53bbbd99273f4f7c4affa855c33c0a" |
| |
| SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ |
| file://weston.png \ |
| file://weston.desktop \ |
| file://xwayland.weston-start \ |
| file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ |
| " |
| SRC_URI[md5sum] = "cbfda483bc2501d0831af3f33c707850" |
| SRC_URI[sha256sum] = "a00a6d207b6a45f95f4401c604772a307c3767e5e2beecf3d879110c43909a64" |
| |
| UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" |
| |
| inherit meson pkgconfig useradd distro_features_check |
| # depends on virtual/egl |
| REQUIRED_DISTRO_FEATURES = "opengl" |
| |
| DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" |
| DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" |
| |
| WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}" |
| |
| EXTRA_OEMESON += "-Dbackend-default=auto -Dbackend-rdp=false -Dpipewire=false" |
| |
| PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ |
| ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd x11', d)} \ |
| ${@bb.utils.contains_any('DISTRO_FEATURES', 'wayland x11', '', 'headless', d)} \ |
| clients launch" |
| # |
| # Compositor choices |
| # |
| # Weston on KMS |
| PACKAGECONFIG[kms] = "-Dbackend-drm=true,-Dbackend-drm=false,drm udev virtual/mesa virtual/libgbm mtdev" |
| # Weston on Wayland (nested Weston) |
| PACKAGECONFIG[wayland] = "-Dbackend-wayland=true,-Dbackend-wayland=false,virtual/mesa" |
| # Weston on X11 |
| PACKAGECONFIG[x11] = "-Dbackend-x11=true,-Dbackend-x11=false,virtual/libx11 libxcb libxcb libxcursor cairo" |
| # Headless Weston |
| PACKAGECONFIG[headless] = "-Dbackend-headless=true,-Dbackend-headless=false" |
| # Weston on framebuffer |
| PACKAGECONFIG[fbdev] = "-Dbackend-fbdev=true,-Dbackend-fbdev=false,udev mtdev" |
| # weston-launch |
| PACKAGECONFIG[launch] = "-Dweston-launch=true,-Dweston-launch=false,drm" |
| # VA-API desktop recorder |
| PACKAGECONFIG[vaapi] = "-Dbackend-drm-screencast-vaapi=true,-Dbackend-drm-screencast-vaapi=false,libva" |
| # Weston with EGL support |
| PACKAGECONFIG[egl] = "-Drenderer-gl=true,-Drenderer-gl=false,virtual/egl" |
| # Weston with lcms support |
| PACKAGECONFIG[lcms] = "-Dcolor-management-lcms=true,-Dcolor-management-lcms=false,lcms" |
| # Weston with webp support |
| PACKAGECONFIG[webp] = "-Dimage-webp=true,-Dimage-webp=false,libwebp" |
| # Weston with systemd-login support |
| PACKAGECONFIG[systemd] = "-Dsystemd=true -Dlauncher-logind=true,-Dsystemd=false -Dlauncher-logind=false,systemd dbus" |
| # Weston with Xwayland support (requires X11 and Wayland) |
| PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false" |
| # colord CMS support |
| PACKAGECONFIG[colord] = "-Dcolor-management-colord=true,-Dcolor-management-colord=false,colord" |
| # Clients support |
| PACKAGECONFIG[clients] = "-Dsimple-clients=all -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false" |
| # Virtual remote output with GStreamer on DRM backend |
| PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer-1.0" |
| # Weston with PAM support |
| PACKAGECONFIG[pam] = "-Dpam=true,-Dpam=false,libpam" |
| |
| do_install_append() { |
| # Weston doesn't need the .la files to load modules, so wipe them |
| rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la |
| |
| # If X11, ship a desktop file to launch it |
| if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then |
| install -d ${D}${datadir}/applications |
| install ${WORKDIR}/weston.desktop ${D}${datadir}/applications |
| |
| install -d ${D}${datadir}/icons/hicolor/48x48/apps |
| install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps |
| fi |
| |
| if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then |
| install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland |
| fi |
| |
| if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then |
| chmod u+s ${D}${bindir}/weston-launch |
| fi |
| } |
| |
| PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ |
| libweston-${WESTON_MAJOR_VERSION} ${PN}-examples" |
| |
| FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}" |
| |
| FILES_libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so" |
| SUMMARY_libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'." |
| |
| FILES_${PN}-examples = "${bindir}/*" |
| |
| FILES_${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so" |
| RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland" |
| |
| RDEPENDS_${PN} += "xkeyboard-config" |
| RRECOMMENDS_${PN} = "weston-conf liberation-fonts" |
| RRECOMMENDS_${PN}-dev += "wayland-protocols" |
| |
| USERADD_PACKAGES = "${PN}" |
| GROUPADD_PARAM_${PN} = "--system weston-launch" |