| SUMMARY = "a fast C/C++ compiler cache" |
| DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| by caching the result of previous compilations and detecting when the \ |
| same compilation is being done again. Supported languages are C, C\+\+, \ |
| Objective-C and Objective-C++." |
| HOMEPAGE = "http://ccache.samba.org" |
| SECTION = "devel" |
| |
| LICENSE = "GPLv3+" |
| LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=985be6d06a50f60a9893a19a6d2550b8" |
| |
| DEPENDS = "zstd" |
| |
| SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz" |
| SRC_URI[sha256sum] = "357a2ac55497b39ad6885c14b00cda6cf21d1851c6290f4288e62972665de417" |
| |
| UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/" |
| |
| inherit cmake |
| |
| PATCHTOOL = "patch" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc" |
| PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis" |