SUMMARY = "Python bindings and utilities for GeoJSON" | |
HOMEPAGE = "https://pypi.org/project/geojson/" | |
LICENSE = "BSD-3-Clause" | |
LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f77f2ed49768c8d4c79ba874c0f94d8a" | |
SRC_URI[sha256sum] = "ff3d75acab60b1e66504a11f7ea12c104bad32ff3c410a807788663b966dee4a" | |
inherit pypi setuptools3 ptest | |
SRC_URI += " \ | |
file://run-ptest \ | |
" | |
RDEPENDS:${PN}-ptest += " \ | |
${PYTHON_PN}-pytest \ | |
" | |
do_install_ptest() { | |
install -d ${D}${PTEST_PATH}/tests | |
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | |
} | |
RDEPENDS:${PN} += "python3-simplejson python3-math" | |
BBCLASSEXTEND = "native nativesdk" |