| SUMMARY = "Control Software for VCU" |
| DESCRIPTION = "Control software libraries, test applications and headers provider for VCU" |
| LICENSE = "Proprietary" |
| LIC_FILES_CHKSUM = "file://LICENSE.md;md5=03a7aef7e6f6a76a59fd9b8ba450b493" |
| |
| XILINX_VCU_VERSION = "1.0.0" |
| XILINX_RELEASE_VERSION = "v2019.1" |
| PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" |
| |
| BRANCH ?= "master-rel-2019.1" |
| REPO ?= "git://github.com/xilinx/vcu-ctrl-sw.git;protocol=https" |
| SRCREV ?= "32b7be620987283f62e4469185da81dddad1071c" |
| |
| BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| SRC_URI = "${REPO};${BRANCHARG}" |
| |
| S = "${WORKDIR}/git" |
| |
| COMPATIBLE_MACHINE = "^$" |
| COMPATIBLE_MACHINE_zynqmp = "zynqmp" |
| |
| PACKAGE_ARCH = "${SOC_FAMILY}" |
| |
| RDEPENDS_${PN} = "kernel-module-vcu" |
| |
| EXTRA_OEMAKE = "CC='${CC}' CXX='${CXX} ${CXXFLAGS}'" |
| |
| do_install() { |
| install -d ${D}${libdir} |
| install -d ${D}${includedir}/vcu-ctrl-sw/include |
| |
| install -Dm 0755 ${S}/bin/ctrlsw_encoder ${D}/${bindir}/ctrlsw_encoder |
| install -Dm 0755 ${S}/bin/ctrlsw_decoder ${D}/${bindir}/ctrlsw_decoder |
| |
| oe_runmake install_headers INSTALL_HDR_PATH=${D}${includedir}/vcu-ctrl-sw/include |
| oe_libinstall -C ${S}/bin/ -so liballegro_decode ${D}/${libdir}/ |
| oe_libinstall -C ${S}/bin/ -so liballegro_encode ${D}/${libdir}/ |
| } |
| |
| # These libraries shouldn't get installed in world builds unless something |
| # explicitly depends upon them. |
| |
| EXCLUDE_FROM_WORLD = "1" |