Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "C++ framework for json-rpc 1.0 and 2.0" |
| 2 | DESCRIPTION = "JsonRpc-Cpp is an OpenSource implementation of JSON-RPC \ |
| 3 | protocol in C++. JSON-RPC is a lightweight remote procedure \ |
| 4 | call protocol similar to XML-RPC." |
| 5 | HOMEPAGE = "https://github.com/cinemast/libjson-rpc-cpp" |
| 6 | |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e728c5b36018f6c383b4b9efd9c8840" |
| 9 | SECTION = "libs" |
| 10 | DEPENDS = "curl jsoncpp libmicrohttpd hiredis" |
| 11 | |
| 12 | PV = "1.1.1+git${SRCPV}" |
| 13 | # v1.1.1 |
| 14 | SRCREV = "319783c635cf8cabcc1a980495c99a88f9ebbd97" |
| 15 | |
| 16 | SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp \ |
| 17 | " |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake |
| 22 | |
| 23 | EXTRA_OECMAKE += "-DCOMPILE_TESTS=NO -DCOMPILE_STUBGEN=NO -DCOMPILE_EXAMPLES=NO \ |
| 24 | -DBUILD_SHARED_LIBS=YES -DBUILD_STATIC_LIBS=YES \ |
| 25 | -DCMAKE_LIBRARY_PATH=${libdir} \ |
| 26 | " |
| 27 | |
| 28 | FILES_${PN}-dev += "${libdir}/libjson-rpc-cpp/cmake" |