Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Terminal multiplexer" |
| 2 | HOMEPAGE = "http://tmux.sourceforge.net" |
| 3 | SECTION = "console/utils" |
| 4 | |
| 5 | LICENSE = "ISC" |
| 6 | LIC_FILES_CHKSUM = "file://tmux.c;beginline=3;endline=17;md5=f256b76d52e7b4d02bf19144bdaca107" |
| 7 | |
| 8 | DEPENDS = "ncurses libevent" |
| 9 | |
| 10 | SRC_URI = "https://github.com/tmux/tmux/releases/download/${PV}/tmux-${PV}.tar.gz" |
| 11 | SRC_URI[md5sum] = "d541ff392249f94c4f3635793556f827" |
| 12 | SRC_URI[sha256sum] = "b17cd170a94d7b58c0698752e1f4f263ab6dc47425230df7e53a6435cc7cd7e8" |
| 13 | |
| 14 | inherit autotools pkgconfig |
| 15 | |
| 16 | PACKAGECONFIG ??= "" |
| 17 | PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter," |
| 18 | |
| 19 | do_configure_prepend() { |
| 20 | # The 'compat' directory is needed for output during the build but it's |
| 21 | # not automatically created when building outside the source directory. |
| 22 | mkdir ${B}/compat |
| 23 | } |