Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "libpeas is a gobject-based plugins engine" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/Libpeas" |
| 3 | LICENSE = "LGPLv2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4b54a1fd55a448865a0b32d41598759d" |
| 5 | |
| 6 | DEPENDS = "gnome-common gtk+3 intltool-native" |
| 7 | |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 8 | inherit gnomebase gobject-introspection gtk-doc gtk-icon-cache distro_features_check |
| 9 | |
| 10 | # gobject-introspection is mandatory and cannot be configured |
| 11 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 12 | UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | SRC_URI[archive.md5sum] = "a20dc55c3f88ad06da9491cfd7de7558" |
| 15 | SRC_URI[archive.sha256sum] = "5b2fc0f53962b25bca131a5ec0139e6fef8e254481b6e777975f7a1d2702a962" |
| 16 | |
| 17 | PACKAGECONFIG[python3] = "--enable-python3,--disable-python3,python3-pygobject" |
| 18 | |
| 19 | export GIR_EXTRA_LIBS_PATH = "${B}/libpeas/.libs" |
| 20 | |
| 21 | PACKAGES =+ "${PN}-demo ${PN}-python3" |
| 22 | FILES_${PN}-demo = " \ |
| 23 | ${bindir}/peas-demo \ |
| 24 | ${libdir}/peas-demo \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS_${PN}-python3 = "python3-pygobject" |
| 28 | FILES_${PN}-python3 = "${libdir}/libpeas-1.0/loaders/libpython3loader.so" |