Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require recipes-devtools/gcc/gcc-${PV}.inc |
| 2 | require gcc-target.inc |
| 3 | |
| 4 | # Building with thumb enabled on armv4t fails with |
| 5 | # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs |
| 6 | # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output |
| 7 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 8 | |
| 9 | BBCLASSEXTEND = "nativesdk" |
| 10 | |
| 11 | #SYSTEMHEADERS_class-nativesdk = "${@'${target_includedir}'.replace(d.getVar('SDKPATH', True),'%r')}" |
| 12 | #SYSTEMLIBS_class-nativesdk = "${@'${target_base_libdir}'.replace(d.getVar('SDKPATH', True),'%r')}/" |
| 13 | #SYSTEMLIBS1_class-nativesdk = "${@'${target_libdir}'.replace(d.getVar('SDKPATH', True),'%r')}/" |
| 14 | |