Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 1 | SUMMARY = "Library for obtaining the call-chain of a program" |
| 2 | DESCRIPTION = "a portable and efficient C programming interface (API) to determine the call-chain of a program" |
| 3 | HOMEPAGE = "http://www.nongnu.org/libunwind" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d80c8ed4062b8339b715f90fa68cc9f" |
| 6 | DEPENDS += "libatomic-ops" |
| 7 | DEPENDS:append:libc-musl = " libucontext" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 8 | |
| 9 | SRC_URI = "http://download.savannah.nongnu.org/releases/libunwind/libunwind-${PV}.tar.gz \ |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 10 | file://mips-byte-order.patch \ |
| 11 | file://mips-coredump-register.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | file://0005-ppc32-Consider-ucontext-mismatches-between-glibc-and.patch \ |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 13 | file://0001-src-Gtrace-remove-unguarded-print-calls.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | " |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | |
| 16 | SRC_URI[sha256sum] = "4a6aec666991fb45d0889c44aede8ad6eb108071c3554fcdff671f9c94794976" |
| 17 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 18 | inherit autotools multilib_header |
| 19 | |
| 20 | COMPATIBLE_HOST:riscv32 = "null" |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[lzma] = "--enable-minidebuginfo,--disable-minidebuginfo,xz" |
| 24 | PACKAGECONFIG[zlib] = "--enable-zlibdebuginfo,--disable-zlibdebuginfo,zlib" |
| 25 | PACKAGECONFIG[latexdocs] = "--enable-documentation, --disable-documentation, latex2man-native" |
| 26 | |
| 27 | EXTRA_OECONF = "--enable-static" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 28 | |
| 29 | # http://errors.yoctoproject.org/Errors/Details/20487/ |
| 30 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 31 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 32 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 33 | LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
| 34 | |
| 35 | SECURITY_LDFLAGS:append:libc-musl = " -lssp_nonshared" |
| 36 | CACHED_CONFIGUREVARS:append:libc-musl = " LDFLAGS='${LDFLAGS} -lucontext'" |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 37 | |
| 38 | do_install:append () { |
| 39 | oe_multilib_header libunwind.h |
| 40 | } |
| 41 | |
| 42 | BBCLASSEXTEND = "native" |