Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 1 | # FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'. |
| 2 | # The following is the difference between the old and the new license text. |
| 3 | # Please update the LICENSE value if needed, and summarize the changes in |
| 4 | # the commit message via 'License-Update:' tag. |
| 5 | # (example: 'License-Update: copyright years updated.') |
| 6 | # |
| 7 | # The changes: |
| 8 | # |
| 9 | # --- README |
| 10 | # +++ README |
| 11 | # @@ -1,4 +1,4 @@ |
| 12 | # - Copyright (c) 2005-2020 Paul Marquess. All rights reserved. |
| 13 | # + Copyright (c) 2005-2022 Paul Marquess. All rights reserved. |
| 14 | # This program is free software; you can redistribute it |
| 15 | # and/or modify it under the same terms as Perl itself. |
| 16 | # |
| 17 | # |
| 18 | # |
| 19 | |
| 20 | SUMMARY = "Perl interface to the zlib compression library." |
| 21 | DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \ |
| 22 | to the zlib compression library (see 'AUTHOR' for details about where to \ |
| 23 | get zlib)." |
| 24 | HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib" |
| 25 | SECTION = "libs" |
| 26 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 27 | |
| 28 | LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=9bd174bdd6fbb141c1b679e2466e0b39" |
| 29 | |
| 30 | SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz" |
| 31 | |
| 32 | SRC_URI[sha256sum] = "96e20946eb457a32d2d7a0050b922e37b5ada41246bcdc824196d3f7c4da91b7" |
| 33 | |
| 34 | DEPENDS += "zlib" |
| 35 | |
| 36 | S = "${WORKDIR}/Compress-Raw-Zlib-${PV}" |
| 37 | |
| 38 | inherit cpan |
| 39 | |
| 40 | export BUILD_ZLIB="0" |
| 41 | |
| 42 | do_compile() { |
| 43 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 44 | cpan_do_compile |
| 45 | } |
| 46 | |
| 47 | BBCLASSEXTEND = "native" |