blob: 676fbae7ed18318eacafd5b9bbbfc7f6eb1249fa [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
2HOMEPAGE = "https://github.com/aio-libs/multidict/"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05003
Brad Bishop26bdd442019-08-16 17:08:17 -04004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
6
Andrew Geisslera2681d92020-10-16 10:17:07 -05007SRC_URI[md5sum] = "c2c3311e25636a6f213e998cd1e80d72"
8SRC_URI[sha256sum] = "1b324444299c3a49b601b1bf621fc21704e29066f6ac2b7d7e4034a4a18662a1"
Brad Bishop26bdd442019-08-16 17:08:17 -04009
Andrew Geissler2ee498a2020-05-29 15:52:06 -050010inherit pypi setuptools3 ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS_${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler2ee498a2020-05-29 15:52:06 -050024
25BBCLASSEXTEND = "native nativesdk"