Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "pandas library for high-performance data analysis tools" |
| 2 | DESCRIPTION = "pandas is an open source, BSD-licensed library providing \ |
| 3 | high-performance, easy-to-use data structures and data analysis tools for \ |
| 4 | the Python programming language." |
| 5 | HOMEPAGE = "http://pandas.pydata.org/" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 9 | SRC_URI[md5sum] = "594e6a429f297c77470e37d3510cccbb" |
| 10 | SRC_URI[sha256sum] = "a979d0404b135c63954dea79e6246c45dd45371a88631cdbb4877d844e6de3b6" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | 2ee498a | 2020-05-29 15:52:06 -0500 | [diff] [blame] | 12 | inherit pypi setuptools3 |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS += " \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | " |
| 17 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 18 | CFLAGS_append_toolchain-clang = " -Wno-error=deprecated-declarations" |
| 19 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | RDEPENDS_${PN} += " \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | ${PYTHON_PN}-json \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | ${PYTHON_PN}-numpy \ |
| 23 | ${PYTHON_PN}-dateutil \ |
| 24 | ${PYTHON_PN}-pytz \ |
| 25 | " |