Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)" |
| 2 | DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \ |
| 3 | from the CPUID instruction, and also determines the exact model of CPU(s). \ |
| 4 | It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \ |
| 5 | UMC, NexGen, Rise, and SiS CPUs" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 6 | HOMEPAGE="http://www.etallen.com/cpuid.html" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 9 | |
| 10 | SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \ |
| 11 | " |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "13c53f16408341d11ed489b352f218ec4dbb5bedb796a9d059e924770a9c56a6" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 15 | |
| 16 | inherit perlnative |
| 17 | |
| 18 | # The install rule from the Makefile has hardcoded paths, so we duplicate |
| 19 | # the actions to accommodate different paths. |
| 20 | do_install () { |
| 21 | install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid |
| 22 | install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir} |
| 23 | } |